PHP 5.4 Server Upgrade

In order to better serve our customers, iCreate HostingĀ is making an important upgrade for your server’s default PHP configuration.

The default version of PHP has now been upgradedĀ to PHP 5.4. This change will ensure a more secure and stable hosting environment going forward.

To help make this transition as smooth as possible, please log into your cPanel and test all of your sites using PHP 5.4 by following these steps:

  1. Login to your cPanel at http://yourdomain.com/cpanel
  2. Click on the “PHP Configuration” icon, which can be found under the “Advanced” group of icons in cPanel.
  3. From the drop-down of Available PHP handlers, please select “PHP 5.4” without changing the target directory from the current setting. It should be displaying / (Current Folder). Click on “Update”
  4. You should see a confirmation message that reads: The “.php” file extension will be processed by PHP 5.4 for this account. Clicking on the “Back to” button you should now notice that the dropdown should be listing PHP 5.4 as the active Handler
  5. At this point you will want to test your sites by opening in a browser and see if they load with any errors. If you do not notice any issues this means your sites are compatible with PHP 5.4 and you do not need to perform any further actions – simply leave the Handler set as it is, without any other changes.
  6. If on the other hand, you DO notice issues during your test with your sites while the PHP 5.4 Handler is enabled, simply reset it to use “PHP 5.2”. This will set your account to specifically use that version of PHP once the PHP upgrade process is performed. These settings will be maintained once completed.

If you have any problems, contact us.